Fork von zaininnari/html-minifier mit PHP 7.3 Kompatiblität


Datum: 24.02.2019 19:53

Ich nutze in UliCMS das Composer-Package zaininnari/html-minifier.

Ich habe testweise ein Upgrade auf PHP 7.3 durchgeführt
Besagtes Composer Package warf dann mehrfach folgende Warning:

Warning: "continue" targeting switch is equivalent to "break". Did you mean to use "continue 2"? in 
[...]/vendor/zaininnari/html-minifier/src/zz/Html/HTMLTokenizer.php on line xyz

Da sich der Entwickler des ursprünglichen Pakets sich seit 2015 nicht mehr darum gekümmert hat, habe ich es kurzerhand geforkt um den Fehler selber zu beheben.

deruli/html-minifier auf Packagist

Mein Fork enthält zusätzlich zu der Kompatiblität mit PHP 7.3 noch einen weiteren Bugfix eines anderen Entwicklers, der ebenfalls noch nicht in das ursprüngliche Projekt gemerged wurde.

Ihr könnt einfach in eurer composer.json zaininnari/html-minifier durch mein Package ersetzen, "composer update" ausführen und die PHP Warning ist weg.

Kommentare

Name: *  
Homepage:  
Email: *  



Es sind bisher noch keine Kommentare zu diesem Artikel vorhanden.

Don't click this link